Welcome To V6Mustang.com!

We are the oldest and largest V6 Mustang forum on the internet. If you have any questions about your V6 Mustang or just want to connect with other V6 Mustang owners around the world, you have found the best place on the internet to do that.

Registering is free and easy! Hope to see you on the forums soon!

05 v6 mustang pulsing idle

Discussion in '2005-2010 V6 Mustang Tech' started by Troupster, Sep 9, 2017.

  1. Troupster

    Troupster New Member

    Joined:
    Sep 9, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hey guys, I've read a ton of threads and tried to tackle this myself, but I think I may need to take it to a shop. Basically the car is just acting a bit rough at idle, and I'll run you through what I've done:

    -Cleaned throttle body plate and interior
    -Cleaned MAF, actually replaced MAF
    -Seafoamed through throttle body
    -Seafoamed through gas tank
    -Replaced spark plugs ( but not wires yet )
    -Replaced air filters
    -Replaced fuel filter
    -Performed Ford idle reset procedure

    At this point I'm guessing there's a small leak in a hose or my O2 sensors are bad, but before I take it in I thought I'd ask if anyone knows?

    It happens when it's hot, and seemingly certain angles of the road may affect it, which leads me to believe it's a vacuum leak.

    One final thing I've noticed, there's a bit of a hiss when I turn off the car from the passenger side of the engine, is that normal?

    The car has 70k miles btw.

    Thanks for any help in advance, I'll attach some RPM meter I took, you can see the dips, and no there's no engine codes or failures.
     

    Attached Files: