Welcome To V6Mustang.com!

We are the oldest and largest V6 Mustang forum on the internet. If you have any questions about your V6 Mustang or just want to connect with other V6 Mustang owners around the world, you have found the best place on the internet to do that.

Registering is free and easy! Hope to see you on the forums soon!

2009 mustang radio quit working

Discussion in '2005-2010 V6 Mustang Tech' started by Aaron Hutch, Apr 15, 2014.

  1. Aaron Hutch

    Aaron Hutch New Member

    Joined:
    Apr 15, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have a 2009 4.0L and today the radio just quit. I have had the car for 4 years and never had a single problem. Today the radio was working just fine, I was picking my son up at school, pulled in shut the car off and the radio stayed on until I opened the door as it always does. I got back into the car and the radio had no power at all, no clock, nothing. I pushed all the buttons a dozen times and still nothing. I got it home, checked the fuses inside and under the hood and still nothing. I disconnected the negative battery terminal, cleaned the corrosion, tested every single fuse with a meter and they were all good. I probably had the battery unhooked for about 10 minutes. When I hooked the negative back up it magically worked. I am just scared that it will happen again and wondered if anyone else has had this issue. Thanks for any answers that anyone may have.
     
    Last edited: Apr 15, 2014
  2. unit1stealth

    unit1stealth Member

    Joined:
    Dec 10, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    You should try and remove the radio unit from the dash. I actually swapped mine out with an aftermarket double-din unit. I did notice that the factory cables appeared loosely attached to the factory radio. So maybe one of them unplugged itself from the back? (Removing the unit takes less than 10 minutes. It's a very easy process.)

    Best of luck.
     
  3. getsidewayzdrift

    getsidewayzdrift one- wheel peelin!

    Joined:
    Apr 28, 2014
    Messages:
    415
    Likes Received:
    41
    Trophy Points:
    38
    Location:
    Rockledge, Florida
    I know that I have a 2000 and some of the connections are loose, I use a lil Russian ingenuity To fix it when it stops randomly, usually a good tap or two works for me, don't hit the screen, I just haven't gotten around to takingit out and fixing it