Welcome To V6Mustang.com!

We are the oldest and largest V6 Mustang forum on the internet. If you have any questions about your V6 Mustang or just want to connect with other V6 Mustang owners around the world, you have found the best place on the internet to do that.

Registering is free and easy! Hope to see you on the forums soon!

Blinker Wont Work

Discussion in 'Introductions' started by Kmay15, Feb 4, 2019.

  1. Kmay15

    Kmay15 New Member

    Joined:
    Feb 4, 2019
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Recently I replaced my stock steering wheel with an aftermarket steering wheel and also changed out the bulbs in my instrumental gauge cluster with LEDs. After doing all of this my blinkers did not work when in use. My hazards work but when i put them on the only one that doesn't work is my front left blinker. Sometimes I try and use my blinker on my right side and it seems like it wants to work but it doesn't blink. sometimes it just stays on or doesn't come on at all. Haven't tried anything yet and wanted to see if anybody could help with the issue. Thanks!
     
  2. 08'MustangDude

    08'MustangDude Active Member

    Joined:
    Jan 31, 2018
    Messages:
    274
    Likes Received:
    43
    Trophy Points:
    38
    Replace the blinker with an electronic one for LEDs. The LEDs are not
    drawing enough current to set off the blinker. Or, you buy load resisters
    and wire them in parallel, but then you're still using the same amount of
    current as you were. I use LEDs specifically for lower power consumption,
    and if they don't work then I won't use them. I will not use load resisters..