Welcome To V6Mustang.com!

We are the oldest and largest V6 Mustang forum on the internet. If you have any questions about your V6 Mustang or just want to connect with other V6 Mustang owners around the world, you have found the best place on the internet to do that.

Registering is free and easy! Hope to see you on the forums soon!

engine misfiring.

Discussion in '1994-2004 V6 Mustang Tech' started by Arthur, Sep 14, 2018.

  1. Arthur

    Arthur New Member

    Joined:
    Jun 14, 2018
    Messages:
    20
    Likes Received:
    2
    Trophy Points:
    3
    My 03 six cyl automatic is stumbling on acceleration under moderate load. 135000 miles. I'm thinking spark plugs. I just bought it two months ago and it was running fine until this week. Any other advice,please.
     
  2. fasterthanyou

    fasterthanyou Active Member

    Joined:
    Feb 9, 2013
    Messages:
    510
    Likes Received:
    52
    Trophy Points:
    38
    Location:
    South Florida
    Something ignition related. Plugs, plug wires, ignition coil.
     
  3. Serpent

    Serpent Active Member

    Joined:
    Feb 8, 2017
    Messages:
    133
    Likes Received:
    8
    Trophy Points:
    28
  4. Arthur

    Arthur New Member

    Joined:
    Jun 14, 2018
    Messages:
    20
    Likes Received:
    2
    Trophy Points:
    3
    Plugs. changed them today. They looked like original,130000 miles. I just bought the car two months ago. success.
     
  5. Sauceja

    Sauceja Member

    Joined:
    Jun 1, 2018
    Messages:
    48
    Likes Received:
    16
    Trophy Points:
    8
    I have been reading a lot about coil packs going out and common symptom is power loss under a load.
    So if problem continues may be worth looking into. And they aren't extremely expensive.