Welcome To V6Mustang.com!

We are the oldest and largest V6 Mustang forum on the internet. If you have any questions about your V6 Mustang or just want to connect with other V6 Mustang owners around the world, you have found the best place on the internet to do that.

Registering is free and easy! Hope to see you on the forums soon!

Hello, everyone

Discussion in 'Mustang Talk' started by MineralGrey02, Dec 10, 2016.

  1. MineralGrey02

    MineralGrey02 New Member

    Joined:
    Dec 10, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I bought a stock 02 mustang v6 a year ago and sometimes I run into some issues. I been teaching myself and have some knowledge about the 3.8 v6. But more importantly about a week ago I ordered a MSD coil pack for 01-04 mustang v6 from Summit Racing. It came in today and when I was about to finish the install the sensor that connects onto the coil pack socket up top wouldn't go in.....no matter how hard I tried it wouldn't go in. I tried my original coil pack and the sensor slid right into the socket very easily took no effort even heard it click. I examined both coil packs and they are identical but the new coil pack's socket just doesn't accept the sensor. I even had a friend of mine come over because he has a 2004 mustang v6 and his sensor wouldn't hook up into the new coil pack either. Anybody ever experience the same problem before? If so what did you do to fix it? Do I need to bend the 4 little blades inside the coil pack's socket?
     
    Last edited: Dec 10, 2016