Project New beginning

38stang

Active Member
Ok I checked my o2's and there are working like they should and both of them are moving these the same amount and at the same time. I can only assume that there is a vacuum leak some were. On the bright side the computer is learning how to compensate for it with the exception of tip-in.
 

38stang

Active Member
Sorry 6 shooter. I haven't been able to send you the info. my laptop with my tuning software died. I'm trying to get it fixed at the first of the year.
 

38stang

Active Member
I know its been a long time since I posted. I got the car running good again and then It took a turn for the worst, started acting like it had a big vac leak. I've found the T-body is really screwed now, I had put new seals in it but they weren't compatible with methanol so the just fell a part after 3 months. I've ordered a new t-body and am hoping this is going to fix every thing now.
 

38stang

Active Member
I got the new T-body and cut up a stock one to get the throttle arm off of it and this is what I got. now I can remove the arm if I need a new T-body ever again.
 

38stang

Active Member
Well I finally made it to the track last Friday to do some tuning and second pass the crank sensor craps out. So just one more set back in a long string. hopefully she will be back up and running today. but on a side not on the first pass I launched the car in 2nd gear to get a good long data log and still managed a 12.90 pass with 14 deg's timing and a bad lean condition.
 

38stang

Active Member
Just a little update:
I fixed my tpms and went back to the track first pass the throttle got stuck open and sent me for a wild ride to the end of the track. I got her slowed down enough to make the u-turn at the end (20mph hard U-turn not fun).
I took the car home and haven't moved it sense, that's been 3weeks Ill be working on it soon and making one more trip before the season is over.
 

Phil II

Cone Destroyer
Damn. I experienced a throttle stuck open one time on the highway. The linkage got stuck on the hose clamp I was using at the time. Lost a tire and smoked the brakes pretty bad.

I'm glad you were able to recover without incident. Have you looked into the cause?
 

JTsStang

Boosted V6
Have you ever looked into the Jon Bond impeller upgrade for the d1sc? Sc rebuilder also see a replacement upgrade but it's design to increase boost down low.

Also remember the third pic? It was a disaster lol.
 

Attachments

  • d1sc1.jpg
    d1sc1.jpg
    279.2 KB · Views: 257
  • d1sc2.jpg
    d1sc2.jpg
    97.6 KB · Views: 229
  • Pic720-1.jpg
    Pic720-1.jpg
    41.8 KB · Views: 225

38stang

Active Member
Sorry I haven't been on here in a while. JTsStang it looks promising but it might give up efficiency on the top end of the rpm.

But good news I got a cool night to go to the track and ran my best
[email protected]
 
Last edited:

38stang

Active Member
Damn. I experienced a throttle stuck open one time on the highway. The linkage got stuck on the hose clamp I was using at the time. Lost a tire and smoked the brakes pretty bad.

I'm glad you were able to recover without incident. Have you looked into the cause?
luckily I didn't have it that bad, things could have been worse.
I couldn't find the cause either and it only happens when its hot or you use your foot on the pedal, if you open it by hand It dosent do it.
 

38stang

Active Member
Here's the video of my pass. Watch the boost gauge on the left of the gauge pod. The gauge maxes at 20psi and it almost wraps around to the vac side.
 

V6procharged

Moderator
luckily I didn't have it that bad, things could have been worse.
I couldn't find the cause either and it only happens when its hot or you use your foot on the pedal, if you open it by hand It dosent do it.
When I had the windstar, I think the throttle got hung on the hood liner so my tuner trimmed down the metal piece that hits to set screw and it never happened again. Might be ur problem as well
 

38stang

Active Member
When I had the windstar, I think the throttle got hung on the hood liner so my tuner trimmed down the metal piece that hits to set screw and it never happened again. Might be ur problem as well

When my t-body hangs I can open the hood force it closed be hand, but when you let go it will pop back open. If you keep forcing it shut it will finally stay until you go wot down the road again.
 

38stang

Active Member
Awesome! Your car leaves straight as an arrow. Work on that 60' and it's got more in it.
I need some suspension and chassis work done thats as good as I can get it with just UPR rear control arms. Every thing else is stock with 200k and no subframe connectors or cage.
 
Top