Welcome To V6Mustang.com!

We are the oldest and largest V6 Mustang forum on the internet. If you have any questions about your V6 Mustang or just want to connect with other V6 Mustang owners around the world, you have found the best place on the internet to do that.

Registering is free and easy! Hope to see you on the forums soon!

Trans. Failing?

Discussion in '1994-2004 V6 Mustang Tech' started by Sorin276, May 26, 2017.

  1. Sorin276

    Sorin276 New Member

    Joined:
    May 5, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    This is my first post, so sorry if it's in the wrong place. Have the 96 base convertible. Auto. Was driving one day, and the transmission randomly started giving me problems. If I keep the gas pedal down, no issues. If I come off the pedal at all, or tap the brake, I have to slow down until it has a chance to shift into first before it can accelerate what so ever. I live way in the boonies, and have to hit 4lane to go to any town, so it's a big issue. Advice?? I'm thinking throttle body, but I am basically illiterate when it comes to the transmission
     
  2. Sorin276

    Sorin276 New Member

    Joined:
    May 5, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I meant valve body.
     
  3. Phil II

    Phil II Cone Destroyer Staff Member

    Joined:
    Sep 19, 2013
    Messages:
    1,442
    Likes Received:
    214
    Trophy Points:
    73
    Location:
    Columbia, South Carolina
    Have you done any maintenance or inspections? I suggest starting with replacing fluid and filter. Look for any damage to the transmission harness while you're down there.
     
  4. Sorin276

    Sorin276 New Member

    Joined:
    May 5, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Waiting on weather to clear so that I can do filter and fluid. How visible would damage to harness be? Your comment and any reply is much appreciated.